For a period on 16 July, some account and settings changes were slower than usual to take effect. Normal access to the platform was unaffected and no data was lost. The issue has been resolved and any delayed changes have now been applied.
Resolved
For a period on 16 July, some account and settings changes were slower than usual to take effect. Normal access to the platform was unaffected and no data was lost. The issue has been resolved and any delayed changes have now been applied.
Identified
For a period on 16 July, some account and settings changes were slower than usual to take effect. Normal access to the platform was unaffected and no data was lost. The issue has been resolved and any delayed changes have now been applied.