Resolved
This issue has been resolved and all recent records are now appearing in search.
Investigating
We are currently investigating an issue affecting search results across the app. Records created or synced in the last 48 hours are not appearing in search, which means responses generated within the app will not reference these recent records.
Our team is actively working on a resolution and we will provide an update as soon as more information is available.